Skip to main content

Blog Archive

ROBLOX Discontinuing Support for Mac OS X 10.5

September

07, 2012

by John Shedletsky


Archive

Mac OS X 10.5 Leopard

ROBLOX puts great effort into developing unified code that runs across multiple platforms — PC, Mac and soon iPad — on a wide variety of hardware and software configurations. This summer, as we ratcheted up development efforts for ROBLOX on mobile devices and tablets, we found the software we use to compile our code was only compatible with either Mac OS X 10.5 (Leopard) or mobile devices. We were faced with a tough decision: maintain a separate code base for OS X 10.5 or discontinue support for it.

In the interest of unified code, fast updates and future expansion to more platforms, we have opted to discontinue support for OS X 10.5. The change will take effect in the next two weeks.

OS X 10.5 users will still be able to browse Roblox.com and participate in all web-based features. Our analytics show less than 1% of ROBLOX players use OS X 10.5. If this change affects you and you’d like to continue playing and building games, we recommend you update your Mac’s operating system to at least OS X 10.6.ROBLOX Home Page

We want to make sure all ROBLOX users on OS X 10.5 have the option of continuing to play and build. We’ve contacted Apple, and the easiest update path is to call and purchase the latest operating system update on physical media. They will also be able to tell you whether your system can handle a more recent version of OS X.


FAQ

Q. Why is ROBLOX discontinuing support for Mac OS X 10.5?

A. We would have to maintain a separate code base for Mac OS X 10.5 because the software we use to compile code for OS X 10.5 is not compatible with that of mobile devices. At this time, we are prioritizing a unified code base and development of ROBLOX for mobile devices.

It’s worth noting that Apple no longer supports OS X 10.5, nor do many common desktop applications, like Chrome and Firefox.

Q: I have a Mac. How can I tell if I’m running Mac OS X 10.5?

A: Go to the Apple Menu, then click About this Mac. If it says less than “Version 10.6”, you will need to upgrade to keep playing and building in ROBLOX.

Mac OS Version Check

Q. How can I update my Mac to keep playing ROBLOX?

A. You can call Apple direct at 1 800 MY APPLE to purchase an OS X update, delivered via physical media. They will tell you whether your system can handle the latest Mac operating system, OS X 10.8 Mountain Lion.

Q. Can I still browse Roblox.com on Mac OS X 10.5?

A. Yes. You can continue to browse the website and participate in all our social and economy features.

Q. Who should I contact with questions?

A. If you have any problems to report, please email info@roblox.com.